[Search]  Search   [Groups]  Back to EA Forum Index  
EA Help Issue  XML
Answers HQ - Questions & Comments  > EA Forums General Discussion
Author Message




Joined: 05/08/2012 01:01:06
Messages: 1
Offline

I am having the same issue.
I tried the web site in Chrome v18.googleupdateswaytoooftentoknowthebuild, Firefox 1v10.0.2 & Internet Explorer 9; which ever build is included in Windows 7 Service Pack 1.
None of the three work.
However it does work from inside a "Origin Enabled" game.
I dislike the suggestion this presents; it seems they're trying to block other browsers perhaps?




Joined: 02/14/2010 07:48:27
Messages: 1
Offline

Can any EA employees help me find out how to have my EA account deleted?
That should be an option for all who have ever created an account, and want their privacy returned.

Thanks



[Avatar]
Joined: 10/25/2010 19:50:25
Messages: 374
Offline

You know, ea is so just... dumb. I go on the help page, and you know the guy said it worked with ME3? I clicked on that and entered random stuff, and right away all the little thingys pop up. BTW, I'm testing them on both google chrome and IE9. I go to do BF2, which I need my help on, and there, staring me right in the face are little gray box's. Again, tested on both IE9 and Chrome. WTF, ea.




Joined: 11/01/2008 20:36:08
Messages: 1
Offline

The Contact-Us button doesn't even work at all for me. It wants me to sign in, yet when I do click to log in, it just appends the hashtag (#) to the end of the URL. No popup, no login page. No way to contact EA support. My issue is account related and the article I found doesn't help me at all. I want to use a different email address, but it said the email is already in use or its invalid. I login with the other email address and it logs me in. My account information uses the email I want to change though. Example: I want to change from name@domain1.com to name@domain2.com, but it wont take accept it. I login with name@domain2.com and I'm logged into the name@domain1.com account. I've logged out, cleared the cache, and even deleted all the EA cookies. I used Google Chrome and Mozilla Firefox and both give me the same result. Searching the help articles didn't turn up anything useful about merging accounts.
EA's support website is so much fail right now, I want to know what the hell the people working on the EA site are doing besides looking like a bunch of morons for not fixing the link to login on the Contact Us page. There isn't even a login link in the grey box (top-right of page) on help.ea.com.




Joined: 04/27/2012 20:50:20
Messages: 14
Offline

Ok, raulonfire found something that worked for me here's what he suggested:

1) Upgraded my browser to IE 9. ( I was using IE 8 and firefox in tandem. Only IE 8 works for EA site. Firefox is hopeless)
2) Logged in to support page, and then typed in Mass Effect 3 in the product box(In your case, type in the product name, whatever it is). Then a drop down appears where you can select your game. If it doesn't come at first try, keep refreshing the page and retyping your game. You should eventually get it right.
3) Once you select your game, another box appears. there you can select the category of your issue,(Tech support , warranty etc etc.)
3) Once category is selected, A third box appears where you should select your platform (xbox, ps3 etc)
4) Once all three boxes are filled, the live chat and email features should be available.

Now if you already have IE 9 like I did, and it still is not working than refresh the page. It may take extreme amounts of refreshing the page, even to the point it just makes you angry, but it should work. When I say extreme I mean more than 12 or so times, and I honestly just got it to work the first time for me. When it does work you will notice an instant change; when it doesn't work the text you type in just sits there, but when it works a dropdown box will instantly appear below which tries to guess your product. If that doesn't happen almost instantly, go ahead and refresh the page, and don't worry about waiting because it will never load...trust me waiting and checking back once in a while was what I had been trying.
Answers HQ - Questions & Comments  > EA Forums General Discussion
Go to: