[Search]  Search   [Groups]  Back to EA Forum Index  
[Error] Failed to initialize the GameStartup Interface!  XML
Crysis  > Crysis Tech Help
Author Message




Joined: 04/29/2012 19:27:19
Messages: 1
Offline

Whenever I launch Crysis 2, I come up with a window saying "Failed to initialize the GameStartup Interface!". I have been told by EA support that my system does not meet the requirements but I have seen people with systems weaker than mine play Crysis 2 on a decent FPS.

[b]DxDiag:[/b] http://www.mediafire.com/?46pj6a5pv4xkkr9

[b]Error Log: [/b]

[code]BackupNameAttachment=" Build(5858) 29 Apr 12 (17 01 40)" -- used by backup system
Log Started at 04/29/12 17:01:40
Running 32 bit version
Executable: C:\Program Files (x86)\EA\Crysis 2\bin32\Crysis2.exe
FileVersion: 1.0.0.5858
ProductVersion: 1.0.0.5858
Using STLport C++ Standard Library implementation
Added MOD directory <engine> to CryPak
Executable Command Line: "C:\Program Files (x86)\EA\Crysis 2\bin32\Crysis2.exe"

Total number of logical processors: 4
Number of available logical processors: 4
Total number of system cores: 2
Number of cores available to process: 2

Processor 0:
CPU: Intel Intel(R) Core(TM) i5-2430M CPU @ 2.40GHz
Family: 6, Model: 10, Stepping: 7
FPU: On-Chip
CPU Speed (estimated): 2394.6 MHz
MMX: not present
SSE: present
3DNow!: not present
Serial number not present or disabled

Processor 1:
CPU: Intel Intel(R) Core(TM) i5-2430M CPU @ 2.40GHz
Family: 6, Model: 10, Stepping: 7
FPU: On-Chip
CPU Speed (estimated): 2394.6 MHz
MMX: not present
SSE: present
3DNow!: not present
Serial number not present or disabled

<17:01:40> Windows 7 64 bit SP 1 (build 6.1.7601)
<17:01:40> System language: English
<17:01:40> Windows Directory: "C:\Windows"
<17:01:40> Prerequisites...
<17:01:40> * Installation of KB940105 hotfix required: no! (either not needed or already installed)
<17:01:40> Local time is 17:01:40 04/29/12, system running for 537 minutes
<17:01:40> 5996MB physical memory installed, 3686MB available, 4095MB virtual memory installed, 38 percent of memory in use
<17:01:40> PageFile usage: 25MB, Working Set: 10MB, Peak PageFile usage: 25MB,
<17:01:40> Current display mode is 1366x768x32, (Unknown graphics card)
<17:01:40> IBM enhanced (101/102-key) keyboard and 8+ button mouse installed
<17:01:40> --------------------------------------------------------------------------------
<17:01:40> Stream Engine Initialization
<17:01:40> GameName: Crysis 2 (TM)
<17:01:40> BuildTime: Feb 24 2011 14:23:48
<17:01:40> Font initialization
<17:01:40> [Error] Error loading the default font from Fonts/default.xml. You're probably running the executable from the wrong working folder.
<17:01:40> System Shutdown
[Error] Runaway thread
[Error] Runaway thread
[Error] Runaway thread
[Error] Runaway thread
[Error] Runaway thread[/code]


My graphics card is Intel HD Graphics 3000, and I know it is not recommended but it is still works. Here are videos of people running Crysis 2 on IHG 3000:

http://www.youtube.com/watch?v=g00Y5K-SE-4

http://www.youtube.com/watch?v=JulMhoJEqfI

http://www.youtube.com/watch?v=hBxzgM9PJAw

http://www.youtube.com/watch?v=LT4gmukMRMc


[b]I don't understand why EA support is telling me my PC can't run this when it can. I believe the problem is something else, so I have come to you guys for support.[/b]

This message was edited 1 time. Last update was at 04/29/2012 17:54:21

Crysis  > Crysis Tech Help
Go to: