[Search]  Search   [Groups]  Back to EA Forum Index  
I've noticed some stuttering, locking it to 60fps doesn't make any difference. ...  XML
FIFA 13  > General Discussion
Author Message


Professional Contract

Joined: 28/06/2011 16:12:39
Messages: 1394
Offline

pcgamerr wrote:
Andybc08 wrote:
x_Ras wrote:I had the same problem with Fifa 12 and i also have a Nvidia card


Same here. Sometimes during close-up shots etc it runs smooth as silk at a solid 60fps, but during general gameplay it bogs down. And the sound sometimes glitches, so it must be something to do with CPU or sound drivers.
if that's what happens to me just like you said demo fifa 13 pc


Yeah that's what I'm getting. Really frustrating because I actually want to buy it on PC, but the stuttering is annoying the * outta me.


Big Money Transfer
[Avatar]
Joined: 26/05/2010 19:38:16
Messages: 3607
Location: London, UK
Offline

I had this problem earlier ago. Having downloaded a Demo tweaker from some Polish site introduced extra stuttering.

When I uninstalled the game and the tweak and redownloaded it from origin again it improved my performance.

1. Firstly disable Origin in game! That for me introduced massive amount of stuttering with the FIFA 13 Demo! Having turned it off it became very smooth.

Go to Origin--->Aplication Settings--->In Game Tab. Then uncheck the tick box for Enable Origin In Game. Then click DONE.

2. Now after checking the option lock to 60 fps. That completely eliminated my lag and stuttering issues. Even with Wait for V-Sync checked. Now it's running smoothly no lag/stutter.

I am playing with GTX 560 Ti and Quad Core Q8400 2.66 GHz, 3 GB RAM at 1920x1200 resolution all high with 4x MSAA.

Now see, it should be a lot more smoother! It's perfect for me now. Lock to 60 fps and Origin in game disabled. Also make sure Windows Aero Theme is disabled from the game settings.

This message was edited 1 time. Last update was at 12/09/2012 03:09:29



"If you wish to make an apple pie from scratch, you must first invent the universe."


Park Captain

Joined: 11/09/2012 12:00:46
Messages: 70
Offline

Andybc08 wrote:
pcgamerr wrote:
Andybc08 wrote:
x_Ras wrote:I had the same problem with Fifa 12 and i also have a Nvidia card


Same here. Sometimes during close-up shots etc it runs smooth as silk at a solid 60fps, but during general gameplay it bogs down. And the sound sometimes glitches, so it must be something to do with CPU or sound drivers.
if that's what happens to me just like you said demo fifa 13 pc


Yeah that's what I'm getting. Really frustrating because I actually want to buy it on PC, but the stuttering is annoying the * outta me.
hope to settle it and get to work the guys at EA to fix in the game, bye


Professional Contract

Joined: 28/06/2011 16:12:39
Messages: 1394
Offline

BLaZiNgSPEED wrote:I had this problem earlier ago. Having downloaded a Demo tweaker from some Polish site introduced extra stuttering.

When I uninstalled the game and the tweak and redownloaded it from origin again it improved my performance.

1. Firstly disable Origin in game! That for me introduced massive amount of stuttering with the FIFA 13 Demo! Having turned it off it became very smooth.

Go to Origin--->Aplication Settings--->In Game Tab. Then uncheck the tick box for Enable Origin In Game. Then click DONE.

2. Now after checking the option lock to 60 fps. That completely eliminated my lag and stuttering issues. Even with Wait for V-Sync checked. Now it's running smoothly no lag/stutter.

I am playing with GTX 560 Ti and Quad Core Q8400 2.66 GHz, 3 GB RAM at 1920x1200 resolution all high with 4x MSAA.

Now see, it should be a lot more smoother! It's perfect for me now. Lock to 60 fps and Origin in game disabled. Also make sure Windows Aero Theme is disabled from the game settings.


Tried all this. None of it works.


Scouted

Joined: 02/11/2011 15:17:28
Messages: 500
Offline

The game stutters for me on my 360 lol



Waterboy

Joined: 12/09/2012 01:29:36
Messages: 1
Offline

same here, none of the solutions work, if i put on FRAPS (without recording, just to see the fps), the fps always says 60 - max for my screen (sometimes goes down to 58, never below that).
Shouldn't the game run smoothly then? Still, the game stutters a tiny bit, especially when running across the field.
If I go to instant replay or match highlights after game, it is much better, full speed, no lag whatsoever, but as soon as I start playing, it mini stutters again.

This message was edited 1 time. Last update was at 12/09/2012 07:33:23



Scouted
[Avatar]
Joined: 09/09/2010 13:49:30
Messages: 629
Location: Salem
Offline

Its a never ending story every year.

[WWW]


Park Captain

Joined: 11/09/2012 12:00:46
Messages: 70
Offline

ea lords solve this problem and I reserve the game and hopefully not have this mini-stuttering


League Winner

Joined: 23/05/2011 22:20:35
Messages: 2426
Offline

BLaZiNgSPEED wrote:I had this problem earlier ago. Having downloaded a Demo tweaker from some Polish site introduced extra stuttering.

When I uninstalled the game and the tweak and redownloaded it from origin again it improved my performance.

1. Firstly disable Origin in game! That for me introduced massive amount of stuttering with the FIFA 13 Demo! Having turned it off it became very smooth.

Go to Origin--->Aplication Settings--->In Game Tab. Then uncheck the tick box for Enable Origin In Game. Then click DONE.

2. Now after checking the option lock to 60 fps. That completely eliminated my lag and stuttering issues. Even with Wait for V-Sync checked. Now it's running smoothly no lag/stutter.

I am playing with GTX 560 Ti and Quad Core Q8400 2.66 GHz, 3 GB RAM at 1920x1200 resolution all high with 4x MSAA.

Now see, it should be a lot more smoother! It's perfect for me now. Lock to 60 fps and Origin in game disabled. Also make sure Windows Aero Theme is disabled from the game settings.


Thanks!


Park Captain

Joined: 11/09/2012 12:00:46
Messages: 70
Offline

BLaZiNgSPEED wrote:I had this problem earlier ago. Having downloaded a Demo tweaker from some Polish site introduced extra stuttering.

When I uninstalled the game and the tweak and redownloaded it from origin again it improved my performance.

1. Firstly disable Origin in game! That for me introduced massive amount of stuttering with the FIFA 13 Demo! Having turned it off it became very smooth.

Go to Origin--->Aplication Settings--->In Game Tab. Then uncheck the tick box for Enable Origin In Game. Then click DONE.

2. Now after checking the option lock to 60 fps. That completely eliminated my lag and stuttering issues. Even with Wait for V-Sync checked. Now it's running smoothly no lag/stutter.

I am playing with GTX 560 Ti and Quad Core Q8400 2.66 GHz, 3 GB RAM at 1920x1200 resolution all high with 4x MSAA.

Now see, it should be a lot more smoother! It's perfect for me now. Lock to 60 fps and Origin in game disabled. Also make sure Windows Aero Theme is disabled from the game settings.
this does not work for me, this is my pc, i5 2500k microprocessor, graphic card nvidia gtx 580, 8GB RAM, 1TB seagate HDD. and still a slight stutter todabia in the game,

This message was edited 1 time. Last update was at 12/09/2012 14:26:11



Big Money Transfer
[Avatar]
Joined: 26/05/2010 19:38:16
Messages: 3607
Location: London, UK
Offline

What Nvidia drivers are you using?
What you could try is turn off MSAA from the in game settings and force MSAA through Nvidia Control Panel by adding the FIFA 13 Demo in Manage 3D Settings--->Program Settings. Put 4x MSAA.

I used some FIFA 13 Demo tweaker yesterday which caused more stuttering. I had to uninstall the tweaker and redownload FIFA 13 Demo from Origin and it was smooth again.

Also certain Nvidia drivers are problematic. I use 290.53 Beta drivers and it runs the FIFA 13 Demo perfectly with no lag/stuttering, etc.
You shouldn't have any problems with stuttering, your PC is much more powerful than mine.

Oh, forgot to ask, is your monitors/TV refresh rate set to 60 Hz? Make sure your screen is set to 60 Hz refresh rate then you'll get 60 frames per second with V-Sync on.

This message was edited 1 time. Last update was at 12/09/2012 15:44:43



"If you wish to make an apple pie from scratch, you must first invent the universe."


Park Captain

Joined: 11/09/2012 12:00:46
Messages: 70
Offline

BLaZiNgSPEED wrote:What Nvidia drivers are you using?
What you could try is turn off MSAA from the in game settings and force MSAA through Nvidia Control Panel by adding the FIFA 13 Demo in Manage 3D Settings--->Program Settings. Put 4x MSAA.

I used some FIFA 13 Demo tweaker yesterday which caused more stuttering. I had to uninstall the tweaker and redownload FIFA 13 Demo from Origin and it was smooth again.

Also certain Nvidia drivers are problematic. I use 290.53 Beta drivers and it runs the FIFA 13 Demo perfectly with no lag/stuttering, etc.
You shouldn't have any problems with stuttering, your PC is much more powerful than mine.

Oh, forgot to ask, is your monitors/TV refresh rate set to 60 Hz? Make sure your screen is set to 60 Hz refresh rate then you'll get 60 frames per second with V-Sync on.
I'm using drivers 301.42 I will try that what you say to see if it works.

This message was edited 1 time. Last update was at 12/09/2012 15:49:36



Professional Contract

Joined: 28/06/2011 16:12:39
Messages: 1394
Offline

BLaZiNgSPEED wrote:What Nvidia drivers are you using?
What you could try is turn off MSAA from the in game settings and force MSAA through Nvidia Control Panel by adding the FIFA 13 Demo in Manage 3D Settings--->Program Settings. Put 4x MSAA.

I used some FIFA 13 Demo tweaker yesterday which caused more stuttering. I had to uninstall the tweaker and redownload FIFA 13 Demo from Origin and it was smooth again.

Also certain Nvidia drivers are problematic. I use 290.53 Beta drivers and it runs the FIFA 13 Demo perfectly with no lag/stuttering, etc.
You shouldn't have any problems with stuttering, your PC is much more powerful than mine.

Oh, forgot to ask, is your monitors/TV refresh rate set to 60 Hz? Make sure your screen is set to 60 Hz refresh rate then you'll get 60 frames per second with V-Sync on.


301.42

I've tried all the fixes that I can find on the web and not a single one has worked. Some have helped a bit, but it's still not smooth at all.
It runs at 60FPS, but stutters like a *. Kind of like microstuttering that people with quad cores and hyperthreading used to get.
It's clearly not my PCs fault considering I can get 60FPS smooth parts every now and then (taking corners/free kicks/celebrations) etc.

This message was edited 1 time. Last update was at 12/09/2012 16:08:01



Park Captain

Joined: 11/09/2012 12:00:46
Messages: 70
Offline

BLaZiNgSPEED wrote:What Nvidia drivers are you using?
What you could try is turn off MSAA from the in game settings and force MSAA through Nvidia Control Panel by adding the FIFA 13 Demo in Manage 3D Settings--->Program Settings. Put 4x MSAA.

I used some FIFA 13 Demo tweaker yesterday which caused more stuttering. I had to uninstall the tweaker and redownload FIFA 13 Demo from Origin and it was smooth again.

Also certain Nvidia drivers are problematic. I use 290.53 Beta drivers and it runs the FIFA 13 Demo perfectly with no lag/stuttering, etc.
You shouldn't have any problems with stuttering, your PC is much more powerful than mine.

Oh, forgot to ask, is your monitors/TV refresh rate set to 60 Hz? Make sure your screen is set to 60 Hz refresh rate then you'll get 60 frames per second with V-Sync on.
what you say does not work, in addition to simply test the 306.02 driver, Driver 304.79, 301.42 Driver, Driver 296.10, 295.51 beta driver and does not work yet mild stuttering, and seek no more, just hope they resolve this issue. because I have the game reserve in origin


Professional Contract

Joined: 28/06/2011 16:12:39
Messages: 1394
Offline

Getting a bit * off because by the looks of things I'm gonna have to buy it on 360...
FIFA 13  > General Discussion
Go to: